Переезжаем

August 17, 2008 PHP SliceHost wordpress Новости

До 20 числа мои сайты переезжают на новенький vps от slicehost. В связи с этим возможны неполадки/даунтайм, кроме того, могут пропадать письма на me@coldflame.in.ua – пишите на leonidshevtsov@gmail.com.

Собрал PHP 5.3 на апаче 2.2.9 – с этим была куча проблем, ибо стандартная сборка апача не подходит, нам под монгрел-кластер нужен mod_proxy_balancer. И PHP 5.3 в репозитариях, конечно, не лежит. Получил опыт сборки вебсервера из исходников.

Почему PHP 5.3? Я решил пойти впереди планеты всей и писать с использованием namespace-ов. Да и garbage collector нужен.

WordPress на PHP 5.3 так просто не работает – нужно допиливать wp_settings.php. Проблема в нововведенном типе ошибок E_DEPRECATED – «устаревшая конструкция». Вордпресс ими кишит, притом по умолчанию ставит error_reporting(E_ALL & ~E_NOTICE). К счастью, ничего неочевидного.

Со своим кодом все оказалось вообще просто. Кстати, очень рад, что никогда не использовал готовых сборок типа XAMPP и умею сам настроить.

А к поздней осени выпустят стабильную версию PHP 5.3. Или хотя бы RC.

Buy Me a Coffee at ko-fi.com